Warcraft 3 random lag spikes?

This is a discussion on Warcraft 3 random lag spikes? within the Warcraft 3 forum board part of the Hot Games category; I am having a problem with warcraft 3 when i play dota ...i randomly get lag spikes throught the game ...

Page 1 of 3 123 LastLast
Results 1 to 10 of 27
  1. #1
    RockinRobin is offline Wannabe Member
    Array
    Join Date
    Mar 2010
    Posts
    13
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rep Power
    0
    Reputation
    0

    Warcraft 3 random lag spikes?

    I am having a problem with warcraft 3 when i play dota...i randomly get lag spikes throught the game that last 2-5 minutes. i know its not just when im in a game because i will do it even in the title menu and chat rooms. It has to be something with the running of warcraft 3 because if i switch over the window to internet the internet seems to run smooth as ever. like i said the lag spikes come random they can happen every 10 mins or so and last 2 to 5 mins which if you play dota u know that this can be a BIG inconvienance...PLEASE HELP ME im ready to just stop playing it is so annoying

    thanx

    ---------- Post added at 05:57 PM ---------- Previous post was at 05:55 PM ----------

    just to add to it when this lag happens i am the only person that lags its not the whole game for everyone so it has to be something with my game that is actin screwy

    thanx


  2. #2
    Tracky's Avatar
    Tracky is offline Administrator

    Array
    Join Date
    Dec 2007
    Location
    Germany
    Posts
    9,857
    Mentioned
    158 Post(s)
    Tagged
    2 Thread(s)
    Rep Power
    42
    Reputation
    5607
    Whats your OS.
    What AV are you using ( Firewall aswell ).
    Did you update all your drivers ?
    Have you tried to turn on background programs ?

  3. #3
    RockinRobin is offline Wannabe Member
    Array
    Join Date
    Mar 2010
    Posts
    13
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rep Power
    0
    Reputation
    0
    I am on Windows 7...i have norton internet security...i did one update for nvidia driver...and what do u mean by turn on background programs?

  4. #4
    Daniel999's Avatar
    Daniel999 is offline bla

    Array
    Join Date
    Apr 2009
    Location
    Germany
    Posts
    2,182
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rep Power
    15
    Reputation
    1083
    Quote Originally Posted by RockinRobin View Post
    I am on Windows 7...i have norton internet security...i did one update for nvidia driver...and what do u mean by turn on background programs?
    He probably ment to say "turn off" not on. Go to your task manager and shut down some useless processes. Don't worry, they will restart too if you restart your pc. Also you should turn off your Anti-Virus while playing. You can try to give the war3.exe process a higher priority
    (Taskmanager -> rightclick war3.exe -> Set priority -> High/Very High)

  5. #5
    RockinRobin is offline Wannabe Member
    Array
    Join Date
    Mar 2010
    Posts
    13
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rep Power
    0
    Reputation
    0
    i tried turning AV off while playing does nothing...i set warc3 to higher priority still nothing... and i ended some of the higher using processes that didnt need to be running and still nothing helps....gettin stressful lol i cant play dota at all i lag more than i actually get to play...i jus dont get it because when i first got the computer everthing ran smooth for about the first month and then all the sudden it started doing this

  6. #6
    Tracky's Avatar
    Tracky is offline Administrator

    Array
    Join Date
    Dec 2007
    Location
    Germany
    Posts
    9,857
    Mentioned
    158 Post(s)
    Tagged
    2 Thread(s)
    Rep Power
    42
    Reputation
    5607
    Did you download the latest Windows Updates ?
    If not, do so.

  7. #7
    RockinRobin is offline Wannabe Member
    Array
    Join Date
    Mar 2010
    Posts
    13
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rep Power
    0
    Reputation
    0
    Yes i did i says it is up to date and there are no updates available for download right now...

  8. #8
    Tracky's Avatar
    Tracky is offline Administrator

    Array
    Join Date
    Dec 2007
    Location
    Germany
    Posts
    9,857
    Mentioned
    158 Post(s)
    Tagged
    2 Thread(s)
    Rep Power
    42
    Reputation
    5607
    You could also try to contact the Warcraft III Support.
    They may be able to help you.
    But make sure that nothing is blocking your Connection ( AV / Firewall / Ports ) and stuff.
    Also you should try to reinstall WC3

  9. The Following User Says Thank You to Tracky For This Useful Post:


  10. #9
    LayA's Avatar
    LayA is offline Advanced Hacker

    Array
    Join Date
    Mar 2010
    Location
    Sydney, Australia
    Posts
    401
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rep Power
    8
    Reputation
    128
    Hmmm, Very interesting thread,

    what are your pc specs?

    ram, and cpu.

    Have you ever tried running war3 in a windowed mode?

    {EDIT} try lowring your resolution. always helps for my laptop.

    Tracky its not a war3 issue, its a pc issue/video issue :O

  11. #10
    Tracky's Avatar
    Tracky is offline Administrator

    Array
    Join Date
    Dec 2007
    Location
    Germany
    Posts
    9,857
    Mentioned
    158 Post(s)
    Tagged
    2 Thread(s)
    Rep Power
    42
    Reputation
    5607
    Quote Originally Posted by LayA View Post

    Tracky its not a war3 issue, its a pc issue/video issue :O

    That's atleast what you guess

Page 1 of 3 123 LastLast

Similar Threads

  1. RT - Random Team
    By TR4NSF0RM3RS in forum Warcraft 3 forum
    Replies: 1
    Last Post: 04-07-2011, 08:06 PM
  2. [aCe] Random Siggies
    By aceofspades in forum Showcase
    Replies: 3
    Last Post: 02-18-2010, 07:28 PM
  3. Random story
    By blazestar220 in forum Maple Story
    Replies: 1
    Last Post: 05-04-2009, 11:55 AM
  4. delay/spikes/lag
    By THMS in forum Warcraft 3 forum
    Replies: 6
    Last Post: 04-16-2009, 08:10 PM
  5. Is this a Bug or something random ??
    By nigel2727 in forum WoW Private Servers
    Replies: 9
    Last Post: 01-25-2008, 09:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •