Install and config problems with Magnos. Help me, someone? Pls?

This is a discussion on Install and config problems with Magnos. Help me, someone? Pls? within the WoW Private Servers board part of the WoW forum category; OK, I read your wonderfull guide, several times, saw your youtube movie and took all the steps you told me, ...

Results 1 to 8 of 8
  1. #1
    araphon1 is offline Newbie
    Array
    Join Date
    Jun 2007
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rep Power
    0
    Reputation
    0

    Question Install and config problems with Magnos. Help me, someone? Pls?

    OK, I read your wonderfull guide, several times, saw your youtube movie and took all the steps you told me, letter by letter, and I still can't get the darn thing to work. So, here is what I do:

    I download everything and install it. First MSQL (or what ever), then mangos tools, then mangos server. The problem is, nothing works as it does in your movies. The installation program, or rather the cmd windows that opens, complains about not finding some files. Which is strange, since I choose the correct wow folder... Anyhow, The windows just blink for a tenth of a sec and disappears. Then, when install is "complete" in lack of a better word, I do the map and dbc extracts manually (by moving the mp thingy, the ap.exe and the .dll file that is needed for the mp thingy into the data folder). I get some dbc files and all the map files and put them in the mangos dir.

    When all this is complete, I add the sbd.sql thingy from the .rar file I downloaded, (SDL.0.64.Full, or something like that) and put it in the sql dir in mangos. I then try to fire up the sqlyog program to import it, but after extracting like, 3kb of the data, it gives me this error:

    Code:
     
    Query:
    CREATE TABLE `areatrigger_involvedrelation` (
    `id` int(11) unsigned NOT NULL default '0' COMMENT 'Identifier',
    `quest` int(11) unsigned NOT NULL default '0' COMMENT 'Quest Identifier',
    PRIMARY KEY  (`id`)
    ) ENGINE=MyISAM DEFAULT CHARSET=utf8 ROW_FORMAT=FIXED COMMENT='Trigger System'
    Error occured at:2007-06-23 00:00:09
    Line no.:9
    Error Code: 1046 - No database selected
    Query:
    CREATE TABLE `areatrigger_involvedrelation` (
    `id` int(11) unsigned NOT NULL default '0' COMMENT 'Identifier',
    `quest` int(11) unsigned NOT NULL default '0' COMMENT 'Quest Identifier',
    PRIMARY KEY  (`id`)
    ) ENGINE=MyISAM DEFAULT CHARSET=utf8 ROW_FORMAT=FIXED COMMENT='Trigger System'
    Error occured at:2007-06-23 00:00:42
    Line no.:9
    Error Code: 1046 - No database selected
    Query:
    CREATE TABLE `areatrigger_involvedrelation` (
    `id` int(11) unsigned NOT NULL default '0' COMMENT 'Identifier',
    `quest` int(11) unsigned NOT NULL default '0' COMMENT 'Quest Identifier',
    PRIMARY KEY  (`id`)
    ) ENGINE=MyISAM DEFAULT CHARSET=utf8 ROW_FORMAT=FIXED COMMENT='Trigger System'
    Error occured at:2007-06-23 00:00:43
    Line no.:9
    Error Code: 1046 - No database selected
    Query:
    CREATE TABLE `areatrigger_involvedrelation` (
    `id` int(11) unsigned NOT NULL default '0' COMMENT 'Identifier',
    `quest` int(11) unsigned NOT NULL default '0' COMMENT 'Quest Identifier',
    PRIMARY KEY  (`id`)
    ) ENGINE=MyISAM DEFAULT CHARSET=utf8 ROW_FORMAT=FIXED COMMENT='Trigger System'
    Error occured at:2007-06-23 00:00:45
    Line no.:9
    Error Code: 1046 - No database selected
    Query:
    CREATE TABLE `areatrigger_involvedrelation` (
    `id` int(11) unsigned NOT NULL default '0' COMMENT 'Identifier',
    `quest` int(11) unsigned NOT NULL default '0' COMMENT 'Quest Identifier',
    PRIMARY KEY  (`id`)
    ) ENGINE=MyISAM DEFAULT CHARSET=utf8 ROW_FORMAT=FIXED COMMENT='Trigger System'
    Error occured at:2007-06-23 00:00:46
    Line no.:9
    Error Code: 1046 - No database selected
    Query:
    CREATE TABLE `account` (
    `id` bigint(20) unsigned NOT NULL auto_increment COMMENT 'Identifier',
    `username` varchar(16) NOT NULL default '',
    `password` varchar(28) NOT NULL default '',
    `gmlevel` tinyint(3) unsigned NOT NULL default '0',
    `sessionkey` longtext,
    `v` longtext,
    `s` longtext,
    `email` varchar(255) NOT NULL default '',
    `joindate` timestamp NOT NULL default CURRENT_TIMESTAMP,
    `banned` tinyint(3) unsigned NOT NULL default '0',
    `last_ip` varchar(30) NOT NULL default '127.0.0.1',
    `failed_logins` int(11) unsigned NOT NULL default '0',
    `locked` tinyint(3) unsigned NOT NULL default '0',
    `last_login` timestamp NOT NULL default '0000-00-00 00:00:00',
    `online` tinyint(4) NOT NULL default '0',
    `tbc` tinyint(3) unsigned NOT NULL default '0',
    PRIMARY KEY  (`id`),
    UNIQUE KEY `idx_username` (`username`),
    KEY `idx_banned` (`banned`),
    KEY `idx_gmlevel` (`gmlevel`)
    ) ENGINE=MyISAM DEFAULT CHARSET=utf8 ROW_FORMAT=DYNAMIC COMMENT='Account System'
    Error occured at:2007-06-23 00:05:44
    Line no.:38
    Error Code: 1046 - No database selected
    Query:
    CREATE TABLE `areatrigger_involvedrelation` (
    `id` int(11) unsigned NOT NULL default '0' COMMENT 'Identifier',
    `quest` int(11) unsigned NOT NULL default '0' COMMENT 'Quest Identifier',
    PRIMARY KEY  (`id`)
    ) ENGINE=MyISAM DEFAULT CHARSET=utf8 ROW_FORMAT=FIXED COMMENT='Trigger System'
    Error occured at:2007-06-23 00:05:59
    Line no.:9
    Error Code: 1046 - No database selected
    Query:
    CREATE TABLE `areatrigger_involvedrelation` (
    `id` int(11) unsigned NOT NULL default '0' COMMENT 'Identifier',
    `quest` int(11) unsigned NOT NULL default '0' COMMENT 'Quest Identifier',
    PRIMARY KEY  (`id`)
    ) ENGINE=MyISAM DEFAULT CHARSET=utf8 ROW_FORMAT=FIXED COMMENT='Trigger System'
    Error occured at:2007-06-23 00:06:01
    Line no.:9
    Error Code: 1046 - No database selected
    Query:
    CREATE TABLE `areatrigger_involvedrelation` (
    `id` int(11) unsigned NOT NULL default '0' COMMENT 'Identifier',
    `quest` int(11) unsigned NOT NULL default '0' COMMENT 'Quest Identifier',
    PRIMARY KEY  (`id`)
    ) ENGINE=MyISAM DEFAULT CHARSET=utf8 ROW_FORMAT=FIXED COMMENT='Trigger System'
    Error occured at:2007-06-23 00:15:08
    Line no.:9
    Error Code: 1046 - No database selected
    Query:
    CREATE TABLE `areatrigger_involvedrelation` (
    `id` int(11) unsigned NOT NULL default '0' COMMENT 'Identifier',
    `quest` int(11) unsigned NOT NULL default '0' COMMENT 'Quest Identifier',
    PRIMARY KEY  (`id`)
    ) ENGINE=MyISAM DEFAULT CHARSET=utf8 ROW_FORMAT=FIXED COMMENT='Trigger System'
    Error occured at:2007-06-23 00:29:21
    Line no.:9
    Error Code: 1046 - No database selected
    I Have absolutely no idea what this means, but I'm hoping that some of you more experienced guys do ^-^

    Anyhow, when I try to fire up the server anyway (using the shortcut on the desktop), the error report sais this:

    Code:
     
    2007-06-23 00:14:53 Using configuration file mangosd.conf.
    2007-06-23 00:14:53 MaNGOS daemon /0.7-SVN (Win32)
    2007-06-23 00:14:53 <Ctrl-C> to stop.
    
    MM   MM         MM   MM  MMMMM   MMMM   MMMMM
    MM   MM         MM   MM MMM MMM MM  MM MMM MMM
    MMM MMM         MMM  MM MMM MMM MM  MM MMM
    MM M MM         MMMM MM MMM     MM  MM  MMM
    MM M MM  MMMMM  MM MMMM MMM     MM  MM   MMM
    MM M MM M   MMM MM  MMM MMMMMMM MM  MM    MMM
    MM   MM     MMM MM   MM MM  MMM MM  MM     MMM
    MM   MM MMMMMMM MM   MM MMM MMM MM  MM MMM MMM
    MM   MM MM  MMM MM   MM  MMMMMM  MMMM   MMMMM
            MM  MMM MaNGOS community forums (Powered by Invision Power Board)
            MMMMMM
    
    2007-06-23 00:14:53 World Database: 127.0.0.1;3306;root;mangos;mangos
    2007-06-23 00:14:53 Login Database: 127.0.0.1;3306;root;mangos;realmd
    2007-06-23 00:14:53 Realm running as realm ID 1
    2007-06-23 00:14:53 ERROR:SQL: UPDATE `character` SET `online` = 0
    2007-06-23 00:14:53 ERROR:SQL ERROR: Table 'mangos.character' doesn't exist
    2007-06-23 00:14:53 Using DataDir c:/mangos/
    2007-06-23 00:14:53 ERROR:SQL: DELETE FROM `corpse` WHERE `bones_flag` = '1'
    2007-06-23 00:14:53 ERROR:SQL ERROR: Table 'mangos.corpse' doesn't exist
    2007-06-23 00:14:53 Initialize data stores...
    2007-06-23 00:14:54 
    2007-06-23 00:14:54 >> Loaded 31 data stores
    2007-06-23 00:14:54 
    2007-06-23 00:14:54 Cleaning up instances...
    2007-06-23 00:14:54 ERROR:SQL: SELECT DISTINCT(`instance`) FROM `creature_respawn` WHERE `instance` <> 0
    2007-06-23 00:14:54 ERROR:query ERROR: Table 'mangos.creature_respawn' doesn't exist
    2007-06-23 00:14:54 ERROR:SQL: SELECT DISTINCT(`instance`) FROM `gameobject_respawn` WHERE `instance` <> 0
    2007-06-23 00:14:54 ERROR:query ERROR: Table 'mangos.gameobject_respawn' doesn't exist
    2007-06-23 00:14:54 ERROR:SQL: SELECT DISTINCT(`instance`) FROM `character_instance`
    2007-06-23 00:14:54 ERROR:query ERROR: Table 'mangos.character_instance' doesn't exist
    2007-06-23 00:14:54 ERROR:SQL: SELECT `id` FROM `instance`
    2007-06-23 00:14:54 ERROR:query ERROR: Table 'mangos.instance' doesn't exist
    2007-06-23 00:14:54 ERROR:SQL: SELECT DISTINCT(`instance`.`id`) AS `id` FROM `instance` LEFT JOIN `character_instance` ON (`character_instance`.`instance` = `instance`.`id`) WHERE (`instance`.`id` = `character_instance`.`instance`) AND (`instance`.`resettime` > 1182550494)
    2007-06-23 00:14:54 ERROR:query ERROR: Table 'mangos.instance' doesn't exist
    2007-06-23 00:14:54 
    2007-06-23 00:14:54 >> Initialized 0 instances, deleted 0 old instances
    2007-06-23 00:14:54 Packing instances...
    2007-06-23 00:14:54 ERROR:SQL: SELECT DISTINCT(`instance`) FROM `character_instance` WHERE `instance` <> 0
    2007-06-23 00:14:54 ERROR:query ERROR: Table 'mangos.character_instance' doesn't exist
    2007-06-23 00:14:54 
    2007-06-23 00:14:54 >> Instance numbers remapped, next instance id is 1
    2007-06-23 00:14:54 Loading Game Object Templates...
    2007-06-23 00:14:54 ERROR:SQL: SELECT MAX(`entry`) FROM `gameobject_template`
    2007-06-23 00:14:54 ERROR:query ERROR: Table 'mangos.gameobject_template' doesn't exist
    2007-06-23 00:14:54 ERROR:Error loading `gameobject_template` table (not exist?)
    Oh, and almost forgot, during the install of mysql, it wont finish properly after doing the security thing. It sais something about opening a port, so I did, but it still didn't work despite several reinstalls of all the programs (mysql, mangos etc.)

    All in all, my server wont work, but since I have done what the guide told me, I guess there must be something wrong with my computer, conflicting software perhaps? Or have I overseen something?

    I would appreciate any helpfull answers

  2. #2
    LiL_ReEpEr_SnIpEr's Avatar
    LiL_ReEpEr_SnIpEr is offline Mentor
    Array
    Join Date
    Jun 2007
    Location
    Pinckney, MI
    Posts
    102
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rep Power
    13
    Reputation
    2
    Is your WoW version 2.0.12?

    Also, I would just recomend to reinstall mangos, watch the video guide while you do it.
    [Removed by XplittR]


  3. #3
    Twinksobe's Avatar
    Twinksobe is offline Member
    Array
    Join Date
    Jun 2007
    Posts
    39
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rep Power
    13
    Reputation
    1
    i agree but do check if you imported the right batch
    on MySQL cause but i still have YET tom make a server

  4. #4
    LiL_ReEpEr_SnIpEr's Avatar
    LiL_ReEpEr_SnIpEr is offline Mentor
    Array
    Join Date
    Jun 2007
    Location
    Pinckney, MI
    Posts
    102
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rep Power
    13
    Reputation
    2
    I havent made my server yet either, but I still try to help other members.
    [Removed by XplittR]


  5. #5
    araphon1 is offline Newbie
    Array
    Join Date
    Jun 2007
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rep Power
    0
    Reputation
    0
    OK, so now I reinstalled mangos. The problem now is that the "part that takes 10 minutes" (the extract thingy in a cmd window) never happens. The install just sais "Executing install sql scripts" but nothing happens. I have waited for a sign of life from the install for about 20 minutes. And my machine isn't a slow one, I assure you.

    My wow folder is c:\world of warcraft and I entered this when i started installing. Since i recognise the cmd windows in the video guide, I'm guessing that the extract files (ad.exe and extract_files.bat or some such) should be in the world of warcraft\Data folder, but they aren't. In order for the extract programs to work, or even fire up properly, they should be there, right? Otherwise the installer can't execute them, right?

    Just a thought. Anyhow, I followed the guide 100% now, so I'm guessing that either my mangos install file is broken, or that my firewall (F-secure) or router is messing things up, as usuall (I have forwarded the required ports for the mysql thingy)...

    I'm beginning to loose faith here, could someone pls save me? XD

  6. #6
    LiL_ReEpEr_SnIpEr's Avatar
    LiL_ReEpEr_SnIpEr is offline Mentor
    Array
    Join Date
    Jun 2007
    Location
    Pinckney, MI
    Posts
    102
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rep Power
    13
    Reputation
    2
    Do you even have burning crusade installed? Also, do you have netframework?
    [Removed by XplittR]


  7. #7
    araphon1 is offline Newbie
    Array
    Join Date
    Jun 2007
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rep Power
    0
    Reputation
    0
    BC is installed, so is all the netframework programs :/

  8. #8
    araphon1 is offline Newbie
    Array
    Join Date
    Jun 2007
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rep Power
    0
    Reputation
    0
    Nvm this post though, I have found another emu that works better. Ill see u around.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •